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1 Introduction 
1.1 About This Document 

The information in this guide is intended for administrators setting up evaluation 
and proof-of-concept deployments of MOTOTRBO Dispatch over IP solutions. This 
document describes the steps required to configure communication with a 
MOTOTRBO Extended Range Direct Mode (ERDM) system. 
For more comprehensive information on the Neocom TRBOnet family of radio 
network software tools, refer to the Documentation section of our web site. 

1.2 About TRBOnet 
TRBOnet is a suite of professional applications for MOTOTRBO digital two-way radio 
networks. TRBOnet manages voice and data communication paths across network 
endpoints. It provides a unified graphical dispatcher workbench interface for the 
entire range of workforce fleet management tasks. 

1.3 Contacts 

Region Phone Email & Support 

EMEA +44 203 608 0598 
info@trbonet.com — general and 
commercial inquiries 

support@trbonet.com — technical 
support 

http://kb.trbonet.com — online 
knowledge base  

Americas +1 872 222 8726 

APAC +61 28 607 8325 

 

http://trbonet.com/downloads/#featuresTab3
mailto:info@trbonet.com
mailto:support@trbonet.com
http://kb.trbonet.com/
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2 System Components 
2.1 TRBOnet Enterprise/Plus 

The TRBOnet software consists of several modules which enable you to build 
enterprise dispatch solutions of different levels of complexity and redundancy. The 
first step in implementing the best solution is determining the topology for the 
customer's system; then identifying the combination of modules to implement the 
best customer solution. 
 

2.2 IP Connection (Wireline Connection) 
TRBOnet Server can be connected to a two-way radio system via an IP connection 
creating a direct communications path for all voice and data information between 
them. The topologies can be in the form of a LAN, WAN, or VLAN and/or any 
combination thereof. 
 

2.3 Wireless Connection (Control Stations) 
If TRBOnet Server doesn’t have an IP connection to the radio system, it can be 
connected via a control station (also known as control radio or donor radio). 
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3 System Description 
The Extended Range Direct Mode system utilizes a time division duplex repeater that 
receives a direct mode transmission and repeats it 90 ms later. This systems's 
primary purpose is to extend direct mode range while utilizing a single frequency. 
A radio initiates a transmission as it does in direct mode and can receive 
transmissions directly from a radio or from the repeater. At the beginning of 
reception, the radio selects the best signal. Therefore, direct mode operation is still 
supported in the absence of the repeater without having to change channels. When 
receiving directly from a radio, the receiving radio displays the talkaround icon. 
When receiving from the repeater, the receiving radio does not display the 
talkaround icon. 
Extended Range Direct Mode is a single site conventional mode solution that 
supports the following features: 

• Voice Calls (Group, Individual and All) 
• IP Data (Unconfirmed Group, Unconfirmed Individual and Confirmed 

Individual) 
• Control (Radio Check, Radio Inhibit and Uninhibit, Remote Monitor, and Call 

Alert) 
• Privacy (Basic, Enhanced, and AES) 
• Restricted Access to System (RAS) 
• Voice Transmitter Interrupt 
• NAI wireline interface for voice and control for 3rd Party Voice and Control 

Applications 
• MNIS Wireline Data gateway for MSI and 3rd Party Data Applications 
• Remote Repeater Programming 
• RDAC 
• Analog CWID and FCC Level 1 Monitoring 

3.1 Interactions between ERDM Radios and Direct Mode Radios 
If both Direct Mode radios and Extended Range Direct Mode radios are 
programmed with the same frequency, color code, and talk group, they are able to 
communicate with each other in direct mode. However, in the presence of the 
Extended Range Direct Mode repeater, there is an imbalance in range that is 
dependent upon the receiving radio. 
The repeater re-transmits either the Direct Mode radio's transmission or the 
Extended Range Direct Mode radio's transmission. However, only the Extended 
Range Direct Mode radio is able to receive the repeater's transmission. Because a 
Direct Mode radio does not receive the repeater's transmission, there is an 
imbalance in coverage. Therefore, it is recommended that Direct Mode and 
Extended Range Direct Mode radios are not used to communicate with each other in 
the presence of the Extended Range Direct Mode repeater. 
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3.2 Licensing 
A software license is required in the repeater for this feature to be operational. 
However, license is not required in the radio. 

3.3 System Topologies 
There are two possible topologies when using the MOTOTRBO Extended Range 
Direct Mode system with TRBOnet software. 

3.3.1 IP Connection to Repeater 
This topology is used when TRBOnet Server has an IP connection to the repeater. 
Note the use of NAI Voice and NAI Data in this configuration. 

TRBOnet 
Server

Repeater
NAI Voice and  NAI Data

IP connection

F1/TS2 F1/TS1

Frequency 1: Time Slot 1
Time Slot 2

 

Figure 1: IP Connection to the repeater 

3.3.2 Connection via Control Station 
This topology is used when TRBOnet Server doesn't have an IP connection to the 
repeater. In this case, it can be connected via a control station (also known as control 
radio or donor radio). 

TRBOnet 
Server

Repeater

F1/TS2 F1/TS1

Frequency 1: Time Slot 1
Time Slot 2

Control Station 
Frequency 1USB + Audio Cable

Voice and Data F1/TS2

F1/TS1

 

Figure 2: Wireless connection to the repeater 
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4 Configuring MOTOTRBO Equipment 
This section describes how to configure MOTOTRBO equipment, such as repeaters, 
control stations and subscriber radios, using MOTOTRBO Customer Programming 
Software (CPS). 

• Launch MOTOTRBO CPS. 
• On the menu bar, select View > Expert. 

4.1 Configuring a Repeater 
This section describes how to configure a repeater to be used in an ERDM system. 

• Connect your repeater to the PC via a programming cable (USB). 
Or, if an IP connection is available and the network parameters are known 
(Remote > IP System Settings), establish a connection to your remote 
repeater (Remote > Connect). 

• Click the Read button on the toolbar. 

 

4.1.1 General Settings 
• In the left pane, select General Settings. 

 

• In the General Settings pane, specify the Radio ID of the repeater. This must 
be a unique Peer ID among the repeaters in a radio system and also not in 
conflict with any other third party application Peer ID. The recommended 
range is from 1 to 255. 
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4.1.2 Network 
• In the left pane, select Network. 

 

• In the Network pane, specify the following parameters: 
 Radio IP 

This is the IP address used by the repeater to communicate with the PC 
(using the USB connection) and has to be unique. To avoid conflicts in case 
there are several stations connected with USB, you can change the third 
octet of the address. 

Network Setting 

If your radio system is on a private network, specify the following network 
parameters: 
 Ethernet IP 

This is the LAN address of the repeater that can be obtained from your 
network details; the last octet of the IP address must be unique for the 
system's local network. 

 Gateway IP 
This is the address of an upstream system (router). If a router exists, specify 
its LAN address here. 

 Gateway Netmask 
Set the Subnet Mask, for example, 255.255.255.0 or 255.255.0.0 
depending on the subnet. 

IP repeater Programming 

 Enable 
Select this checkbox to provide the ability to remotely program the 
repeater. 
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4.1.3 Link Establishment 
• In the left pane, select Link Establishment. 

 

• In the Link Establishment pane, specify the following parameters: 
 Link Type 

From the drop-down list, select Master if you are configuring a master 
repeater, or Peer if you are configuring a peer repeater. 

 Authentication Key 
Specify the authentication key that can optionally be used to access the 
repeater. 

 Master IP 
Enter the Ethernet IP address of the master repeater. 

 Master UDP Port 
Enter the UDP port number of the master repeater. 

 UDP Port 
Enter the UDP port number of this repeater. If you are configuring a master 
repeater, set this value the same as that for Master UDP Port. 
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4.1.4 Channel 
• In the left pane, under Channels, right-click Zone and from the drop-down 

menu, select Add > Digital Channel. 

 

• In the left pane, right-click the channel you have just added and from the 
drop-down menu select Rename, or select the channel and just press F2 on 
the keyboard. Enter a new name for the channel, for example, "ERDM". 

 

• In the ERDM pane, specify the following channel-related parameters. 
 Extended Range Direct Mode 

From the drop-down list, select Enabled. 
 Inbound Color Code and Outbound Color Code 

Use different color codes for the inbound (radio transmission) and 
outbound (repeater) transmissions. 

 Network Application Interface Phone 
Select this option to enable NAI telephony on the repeater's channel. 
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 Enter the same frequency for TX Frequency and RX Frequency. 

Note: Make sure that the channel you have added is the first in 
the list of channels as the repeater will work on the channel 
which is on top of the list. 

 

• Once you have finished configuring the desired repeater parameters, click the 
Write button on the toolbar. 

 



  

10 TRBOnet Enhanced Range Direct Mode — Deployment Guide 

4.2 Configuring a Control Station 
This section describes how to configure the radio to be used as a control station in 
an ERDM system. Control stations are used in the scheme depicted in Figure 2. 

• Connect your radio to the PC via a programming cable. 
• Turn on the radio. 
• Click the Read button on the toolbar. 

 

4.2.1 General Settings 
• In the left pane, select General Settings. 
• In the General Settings pane, specify the following: 
 Radio ID 

Enter the Radio ID of the control station. The default value is 64250. 

Note: This value will then be used as the control station’s 
Radio ID when connecting a control station to the 
TRBOnet Server. See section 5.1.2, Connecting a Control 
Station. 
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4.2.2 Network 
• In the left pane, select Network. 

 

• In the Network pane, specify the following parameters: 
 Radio IP 

This is the IP address used by the radio to communicate with the PC (using 
the USB connection) and has to be unique. To avoid conflicts in case there 
are several stations connected with USB, you can change the third octet of 
the address. 

 Accessory IP 
This is the IP address that is given to the PC by the radio that is connected 
to it. 

Note: This value will then be used as the control station’s 
IP Address when connecting a control station to the 
TRBOnet Server. See section 5.1.2, Connecting a Control 
Station. 

 

 Forward to PC 
From the drop-down list, select Via USB. 
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4.2.3 Contacts 
• In the left pane, select Contacts > Digital and right-click it. Click Add > and 

from the drop-down menu select the type of a call you want to add a contact 
for. 

 

• Enter the Contact Name and Call ID for the contacts you have added. 

4.2.4 RX Group Lists 
• In the left pane, select RX Group Lists > Digital. Right-click it, and choose 

Add > RX Group List. 

 

• In the left pane, select the group you have added. 
• In the right pane, in the Available list select a group, or multiple groups using 

the SHIFT key, and click the Add button. 
As a result, the group(s) will appear in the Members list. 
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4.2.5 Channel 
• In the left pane, select Channels. Right-click it, and choose Add > Zone. 

 

• In the left pane, select the zone you have added. Right-click it, and choose 
Add > Digital Channel. 

 

• In the left pane, select the channel (for example, named ERDM) that has 
previously been added. 

 

• In the right pane, specify the following parameters: 
 Extended Range Direct Mode 

From the drop-down list, select Enabled. 
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 Inbound Color Code and Outbound Color Code 
Use different color codes for the inbound (radio transmission) and 
outbound (repeater) transmissions. 

Note: The Inbound Color Code and Outbound Color Code must 
be the same as the corresponding color codes you have 
specified for the repeater. 

 Option Board 
Select this option to enable the option board capability on the channel. The 
option board must be installed and enabled in the radio otherwise this 
feature will not function. 

 

 In the RX Frequency box, set the same radio frequency that you have 
specified for the repeater. 

 RX Group List 
Select the Group list you have specified in section 4.2.4, RX Group Lists. 

 TX Contact Name 
Select the contact to which a call will be initiated on the channel when 
pressing the PTT button. The contact is selected from the Contact list you 
have created in section 4.2.3, Contacts. 

 
• Once you have finished configuring the desired radio parameters, click the 

Write button on the toolbar. 
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4.3 Configuring a Subscriber Radio 
This section describes how to configure a subscriber radio to be used in an ERDM 
system. 

• Connect your radio to the PC via a programming cable. 
• Turn on the radio. 
• Click the Read button on the toolbar. 

 

4.3.1 General Settings 
• In the left pane, select General Settings. 
• In the General Settings pane, specify the following: 
 Radio ID 

Enter the Radio ID of the radio. This ID is used by other radios to contact 
this radio, for instance, communicating via a private call or text message. 

 GPS 
Select this checkbox to track the location of the radio if the radio is 
equipped with a GPS module. 

 Private calls 
Select this checkbox to enable the initiation of a Private Call on a digital 
channel. When disabled, a prohibit tone will sound when the user tries to 
initiate a Private Call. 
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4.3.2 Network 
• In the left pane, select Network. 

 

• In the Network pane, specify the following parameters. 
 Radio IP 

This is the IP address used by the radio to communicate with the PC (using 
the USB connection) and has to be unique. To avoid conflicts in case there 
are several stations connected with USB, you can change the third octet of 
the address. 

 Forward to PC 
From the drop-down list, select Disabled. 

 ARS Radio ID 
Specify the Radio ID of the ARS server. 

 TMS Radio ID 
Specify the Radio ID of the TMS server. 

Note: The ARS Radio ID and TMS Radio ID must be the same as 
TRBOnet Radio ID in the Repeater settings of TRBOnet 
Server. The recommended value is 64250 for both 
parameters. 
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4.3.3 Contacts 
• In the left pane, select Contacts > Digital and right-click it. Click Add > and 

from the drop-down menu select the type of a call you want to add a contact 
for. 

 

• Enter the Contact Name and Call ID for the contacts you have added. 

4.3.4 RX Group Lists 
• In the left pane, select RX Group Lists > Digital. Right-click it, and choose 

Add > RX Group List. 

 

• In the left pane, select the group you have added. 
• In the right pane, in the Available list select a group, or multiple groups using 

the SHIFT key, and click the Add button. 
As a result, the group(s) will appear in the Members list. 
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4.3.5 Channel 
• In the left pane, select Channels. Right-click it, and choose Add > Zone. 

 

• In the left pane, select the zone you have added. Right-click it, and choose 
Add > Digital Channel. 

 

• In the left pane, select the channel (for example, named ERDM) that has 
previously been added. 

 

• In the right pane, specify the following parameters: 
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 Extended Range Direct Mode 
From the drop-down list, select Enabled. 

 Inbound Color Code and Outbound Color Code 
Use different color codes for the inbound (radio transmission) and 
outbound (repeater) transmissions. 

Note: The Inbound Color Code and Outbound Color Code must 
be the same as the corresponding color codes you have 
specified for the repeater. 

 ARS 
Select On System Change to provide the automated registration for the 
radio. 

 Option Board 
Select this option to enable the option board capability on the channel. The 
option board must be installed and enabled in the radio otherwise this 
feature will not function. 

 

 In the RX Frequency box, set the same radio frequency that you have 
specified for the repeater. 

 RX Group List 
Select the Group list you have specified in section 4.3.4, RX Group Lists. 

 TX Contact Name 
Select the contact to which a call will be initiated on the channel when 
pressing the PTT button. The contact is selected from the Contact list you 
have created in section 4.3.3, Contacts. 
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4.4 Configuring MOTOTRBO DDMS 
The DDMS, or Device Discovery and Mobility Service is a service for tracking the 
presence of radio subscribers in the radio network and transmitting the data to the 
server. The scheme using DDMS is depicted in Figure 1. This section describes how 
to configure and run MOTOTRBO DDMS service using MOTOTRBO DDMS 
Administrative Client. 

• Launch MOTOTRBO DDMS Administrative Client. 
• In the left pane, select Watcher Settings. 

 

 PortWatcher 
This is the port number for listening TRBOnet Server requests. 

Note: This value will be used when configuring DDMS parameters 
in section 5.1.1.2, DDMS Service, Service port. 
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• In the left pane, select Authentication Server Settings. 

 

 AuthenticationServerIP 
This is the authentication server IP address. 

 AuthenticationServerPort 
This is the authentication server port number. 

Note: These values will be used when configuring DDMS 
parameters in section 5.1.1.2, DDMS Service, 
Service IP Address and Authentication Port, respectively. 

 

• Once you have finished configuring the desired DDMS parameters, click the 
Start button on the toolbar. 
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4.5 Configuring MOTOTRBO MNIS 
The MNIS, or Motorola Network Interface Service, is a Windows application which 
acts as a data gateway between the data applications and the radio system. Data 
messages are routed through the MNIS. The topologies using MNIS are depicted in 
Figure 1. This section describes how to configure and run MOTOTRBO MNIS service 
using MNIS Configuration Utility. 

• Launch MNIS Configuration Utility. 
• In the left pane, select General. 

 

 System Operation Mode 
From the drop-down list, select Conventional. 

 MNIS Application ID 
This is an individual ID that uniquely identifies the MNIS application in the 
radio system. The recommended value is 64250. 

Note: This is the ID that TRBOnet Server uses as its Radio ID 
when connecting a master repeater. 

 MNIS IP Address 
It is recommended that the value of 172.168.10.1 is used unless there are 
conflicts with other network interfaces on the PC. 

 Tunnel IP Address 
This is the IP Address used by the MNIS to communicate with TRBOnet 
Enterprise (see 5.1.1.3, MNIS Data Service, IP Address). 
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• In the left pane, select Conventional > Domain 1. 

 

 Master IP Address 
Enter the Ethernet IP address of the master repeater. 

 Master UDP Port 
Enter the UDP port number of the master repeater. 

 Authentication Key 
Enter the master repeater's authentication key (if any). 

 SFR Mode 
Select this option to enable the Single Frequency Repeater (SFR) mode. 

 Repeater Slot 2 Enable 
Select this options so that MNIS will be able to send or receive data over 
the slot. 
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• In the left pane, select Advanced. 

 

 Compressed UDP Data Header 
From the drop-down list, select the type of compression protocol used for 
the UDP Data Header (None, MSI, DMR). It is recommended selecting MSI. 
Note that the same type must be set on all subscriber radio channels 
(CPS>Channels>Compressed UDP Data Header). 

 MNIS LE ID > Manually Assigned 
Enter a unique Peer ID among the repeaters in a radio system. 

 



Configuring MOTOTRBO Equipment 

25 

• In the left pane, select Network. 

 

Device Discovery and Mobile Service 

 Server Address 
This is the IP address of the MOTOTRBO Device Discovery and Mobility 
Service (DDMS). The recommended value is 127.0.0.1 if both DDMS and 
MNIS reside on the same PC. 

 Watcher Port 
This is the port number on the MOTOTRBO Device Discovery and Mobility 
Service (DDMS) server to which the Watcher requests should be sent. 

MNIS Control Interface 

 MNIS Control Interface TCP Port 
This is the Transmission Control Protocol (TCP) port for the MNIS Control 
Interface server. This value is used when connecting TRBOnet Server to 
MNIS Service (see 5.1.1.3, MNIS Data Service, Control port). 
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Once you have finished configuring the desired MNIS parameters, do the following: 
• Click the Save button on the toolbar. 

 

• On the Configuration menu, click Set as Active Configuration. 

 

• Click the Start button on the toolbar. 
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5 Configuring TRBOnet Enterprise 
This section describes how to configure TRBOnet Enterprise software. By properly 
configuring TRBOnet Server and TRBOnet Dispatch Console, you will be able to 
utilize the full capabilities of your Extended Range Direct Mode system. 

5.1 Configuring TRBOnet Server 
To start TRBOnet Server, click the corresponding shortcut on the desktop, 
or click Start > All Programs > Neocom Software > TRBOnet Server x.x 
For instructions on how to configure TRBOnet Server’s Database, Service, Network 
parameters, etc., refer to TRBOnet Enterprise Quick Start Guide. 

5.1.1 Connecting a Repeater 
This section describes how to configure TRBOnet Server for communication with the 
repeater of an ERDM system. 

Note: Only the Master repeater needs to be connected to TRBOnet 
Server. 

• In the Digital Systems pane, click Add. 
Or, in the Configuration pane, right-click Digital Systems. 

• In the drop-down menu, click Add MOTOTRBO System. 
In the Repeater pane, specify the connection parameters. To ensure your 
connection parameters match the actual configuration of your radio network, 
you may need to use Motorola CPS to determine the values. Contact your 
radio network administrator, if you do not have this information. 

 

• System Name 
Enter a name for the repeater. This name will be displayed in the Dispatch 
Console. 
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• TRBOnet Peer ID 
Enter a Peer ID for TRBOnet Server. The Peer ID must be unique among the 
repeaters in the radio system. 

• TRBOnet Radio ID 
Enter the Radio ID, which is a gateway for voice and data. The Radio ID must 
be unique in the radio system. The default value is 64250. 

• TRBOnet Local Port 
Enter the port number on the TRBOnet Server computer that will be used by 
TRBOnet Server to establish a connection to the repeater. Use unique port 
numbers for each repeater connection if there are several repeaters connected. 

• Master IP Address 
Enter the Ethernet IP address of the master repeater. 

Note: This value is programmed for a repeater via MOTOTRBO 
CPS, in Link Establishment>Master IP. See section 4.1.3. 

• Master UDP Port 
Enter the UDP port number of the master repeater. 

Note: This value is programmed for a repeater via MOTOTRBO 
CPS, in Link Establishment>Master UDP Port. See section 
4.1.3. 

• Authentication Key 
Enter the repeater's authentication key (if any). 

Note: This value is programmed for a repeater via MOTOTRBO 
CPS, in Link Establishment>Authentication Key. See section 
4.1.3. 

• System Type 
From the drop-down list, select Extended Range Direct Mode. 

• Test 
Click this button to check the connection to your master repeater. If the test is 
successful, you'll see the information about the repeater you are connected to, 
such as the serial number, firmware version, and other relevant information. 

• System Identifier 
Enter the system identifier. Note that the system identifier should be the same 
for all control stations and repeaters used in the same radio system. 

• Use NAI Voice, Use NAI Data (MNIS and DDMS) 
These options are automatically selected. 

Click Apply after entering all the required values. A confirmation dialog will appear, 
prompting you to save the configuration and restart the TRBOnet Server service. You 
can also restart the service manually. 
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5.1.1.1 Advanced Settings 
• In the Configuration pane, under the corresponding Repeater, select 

Advanced settings. 

 

• In the Advanced Settings pane, specify the following repeater-related 
advanced settings: 
Voice Call Hang Time (ms): 
 Group Call 

This value sets the duration the repeater reserves the channel after the end 
of a group call transmission. During this time, only members of the group 
that the channel is reserved for can transmit. 

 Private Call 
This value sets the duration a radio keeps the private call setup after a user 
releases the PTT button. This is to avoid setting up the call again each time 
a user presses the PTT button to transmit. During this time, other radios can 
still transmit since the channel is essentially idle. After the hang timer 
expires, the radio transmits using the TX Contact Name parameter specified 
for this channel in MOTOTRBO CPS. 

 Emergency Call 
This value sets the duration the repeater reserves the channel after the end 
of an emergency call transmission. During this time, only members of the 
Group that the channel is reserved for can transmit. 

Note: The values of the above three parameters must be taken 
from the corresponding parameter values programmed for 
the repeater via MOTOTRBO CPS in General Settings. 
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 TX Preamble 
Enter the value of the TX Preamble. The TX Preamble is a string of bits 
added in front of a data or control message (Text Messaging, Location 
Messaging, Registration, Radio Check, Private Call, and other message 
types) before transmission. The acceptable range is 0 - 8640 ms. The 
recommended value is 120 ms. 

 TX Timeout 
Enter the time, in seconds, to be used as a voice session limit. When the 
dispatcher starts any voice session in the Dispatch Console, transmission 
will be interrupted after this TX Timeout expires. 

 Phone system 
From the drop-down list, select Motorola Phone System. 

5.1.1.2 DDMS Service 
The DDMS, or Device Discovery and Mobility Service is a service for tracking the 
presence of radio subscribers in the radio network and transmitting the data to the 
server. 

• In the Configuration pane, under the corresponding Repeater, select 
DDMS service. 

 

• In the DDMS service pane, specify the following DDMS service-related 
settings: 
 Use DDMS service 

Select this option to enable the DDMS service for the server. 
 Local Port 

Enter the number of the local port to be used on a PC with TRBOnet 
Dispatch Software for DDMS service. 
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 Service IP Address 
Enter the IP Address of the PC with the DDMS service installed and running. 

 Service port 
Enter the service port number. 

Note: This value is programmed for a DDMS service via 
MOTOTRBO DDMS Administrative Client, in 
Interfaces>Watcher Settings>PortWatcher. 

 Authentication Port 
Enter the authentication server port number. 

Note: This value is programmed for a DDMS service via 
MOTOTRBO DDMS Administrative Client, in 
Interfaces>Authentication Server Settings> 
AuthenticationServerPort. 

 Redundant services 
Here you see the list of redundant DDMS services for failover purposes. 
• Click Add and specify the required parameters for the DDMS service 

being added. 
• Click Test to test if the selected DDMS service is available. 
• Use the Up ( ) and Down ( ) buttons to move a selected DDMS 

service up and down in the priority list of DDMS services. 

5.1.1.3 MNIS Data Service 
MNIS, or Motorola Network Interface Service, is a Windows application which acts as 
a data gateway between the data applications and the radio system. Data messages 
are routed through MNIS. 

• In the Configuration pane, under the corresponding Repeater, select 
MNIS data service. 
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• In the MNIS data service pane, specify the following MNIS data service-
related settings: 
 Use Data Gateway 

Select this option to enable the MNIS data service for the server. 
 Service is on a local host 

Select this option if the MNIS data service will be used on the local PC. 
 IP Address 

Enter the IP Address used by the MNIS to communicate with the PC. 

Note: This value is programmed for a MNIS data service via 
MOTOTRBO MNIS Configuration Utility, and can be 
retrieved from General>Tunnel Network>Tunnel IP Address. 

 Control port 
Enter the number for the MNIS control port. 

Note: This value is programmed for a MNIS data service via 
MOTOTRBO MNIS Configuration Utility, in 
Advanced>Network>MNIS Control Interface TCP Port. 

 MNIS Service 
Select this option, and from the drop-down list select the available MNIS 
service. 

 Redundant services 
Here you see the list of redundant MNIS data services for failover purposes. 
• Click Add and specify the required parameters for the MNIS data service 

being added. 
• Click Test to test if the selected MNIS data service is available. 
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• Use the Up ( ) and Down ( ) buttons to move a selected MNIS data 
service up and down in the priority list of MNIS data services. 

5.1.1.4 Slot SF 
• In the Configuration pane, under the corresponding Repeater, select Slot SF. 

 

• In the Slot SF pane, specify the following slot-related parameters: 
 Name 

Enter a name for the slot. This name will be displayed in the Dispatch 
Console. 

 Messaging Delay 
From the drop-down list, select the inter-repeater messaging delay based 
on the IP network configuration. 
• Normal 

The inter-repeater messaging delay is 60 ms. 
• High 

The inter-repeater messaging delay is 90 ms. 
 Use the slot for RX data only (GPS Revert or Data Revert) 

Select this option to configure the slot so that it will only receive data, thus 
having no transmission capability. 

 Allow TX interrupt 
Select this option to allow interrupting dispatcher transmissions by radios 
that are Transmit Interrupt capable. 

 Always transmit when the PTT is pressed ("Impolite" channel access) 
Select this option so that when the PTT button is pressed, the dispatcher 
will start transmitting regardless of whether the channel is free or not (that 
is any transmission in progress will be interrupted). 
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 Data Call confirmed 
Select this option to enable individual packets in data calls (ARS, GPS, and 
Text Message) on the current slot to be confirmed. 

 Private Call Confirmed 
Select this option to set Private calls on the current slot as confirmed. By 
default, Private calls are unconfirmed. 

 Emergency Alarm Ack 
Select this option so that the Dispatch Console is allowed to acknowledge 
an emergency alarm received via this slot. 

 Emergency Call/Alarm Indication 
Select this option so that audio and visual indication is given for an 
emergency call/emergency alarm received via this slot. 

5.1.2 Connecting a Control Station 
This section describes how to configure TRBOnet Server for communication with a 
control station in an ERDM system. 

• In the Digital Systems pane, click Add. 
Or, in the Configuration pane, right-click Digital Systems. 

• In the drop-down menu, click Add Control Station. 

 

• In the Control Station pane, specify the following control station-related 
parameters: 
 Name 

Enter a name for the control station. This name will be displayed in the 
Dispatch Console. 

 Radio ID 
This is the Radio ID of the radio unit connected as a control station. 
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Note: This box is populated automatically once you have 
successfully tested the control station by clicking the Test 
button. 

 IP Address 
Enter, or select from the list, the IP Address of the control station network 
interface. 

Note: This value can be taken from the radio's configuration in 
MOTOTRBO CPS, in Network>Accessory IP. 

 Test 
Click this button to check the connection to the control station. If the test is 
successful, you'll see the information on the control station you are 
connected to, such as radio ID, serial number, firmware version, and other 
relevant information. 

 Mode 
From the drop-down list, select Single Control Station. 

 System Identifier 
Enter the system identifier. Note that the system identifier should be the 
same for all control stations and repeaters used in the same radio system. 

 Use the radio for RX data only (GPS Revert or Data Revert) 
Select this option to configure the radio channel so that it will only receive 
data, thus having no transmission capability. 

 Playback device 
From the drop-down list, select the playback device on the PC that will be 
used to transfer audio to the control station. 

 Recorder device 
From the drop-down list, select the recording device on the PC that will be 
used to audio from the control station via a line-in jack connection. 

• Click Apply after entering all the required values. A confirmation dialog will 
appear, prompting you to save the configuration and restart the TRBOnet 
Server service. You can also restart the service manually. 

5.1.2.1 Advanced Settings 
• In the Configuration pane, under the corresponding Control Station, select 

Advanced Settings. 
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• In the Advanced Settings pane, specify the following control station-related 
advanced settings: 
 Automatically reset alarm mode 

Select this option to reset alarm mode on the control station radio 
automatically. It is recommended to enable this option. 

 Automatically handle call alert 
Select this option to automatically redirect call alerts from the control 
station radio to the Dispatch Console. 

 Emergency Call/Alarm indication 
Select this option so that audio and visual indication is given by the control 
station radio when an Emergency Call/Emergency Alarm is received. 

 Use front microphone (for PTT key up) 
Select this option to use the speaker microphone on the front of the radio. 

 Always transmit when the PTT is pressed ("Impolite" channel access) 
Select this option so that when the PTT button is pressed, the radio will 
start transmitting regardless of whether the channel is free or not (that is 
any transmission in progress will be interrupted). 

 Use serial port for PTT key up 
Select this option to use a remote control of the PTT button via the serial 
port of the PC, and select the serial port from the drop-down list. 

 TX Timeout 
Enter the time, in seconds, to be used as a voice session limit. When a 
dispatcher starts any voice session in the Dispatch Console, the ongoing 
transmission will be interrupted after this TX Timeout expires. 

 Signaling system 
From the drop-down list, select the signaling system. 
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• MDC 1200 signaling is a Motorola data system using audio frequency 
shift keying (ASFK) using a 1,200 baud data rate. A general option is to 
enable or disable an acknowledgement (ACK) data packet. 

• SELECT 5 (5 Tone Signaling System). In the 5 Tone Signaling Systems, 
each radio has a unique numeric identity (for example, 12345). 

 Allow CSBK Data 
Select this option so that GPS data is sent in a single CSBK. 

5.1.3 Enabling Telephony 
TRBOnet Server has its own built-in SIP server to support VoIP communications 
between the radios as well as other SIP-compliant clients. 

• In the Configuration pane, select Telephony 
• In the Telephony pane, select Use Telephony. 
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5.1.3.1 Internal PBX Server 
• Make sure the Internal PBX Server option is selected in the Telephony pane. 
• In the Configuration pane, select Internal PBX Server. 

 

• In the Internal PBX Server pane, specify the following parameters: 
 Local IP 

Enter the IP address of the PC with TRBOnet Server. 
 Port 

Enter the local UDP port number for the SIP service (5060, by default). 

Dispatch Center 

 SIP ID 
Enter the SIP ID that will be used by the Dispatch Center. 

 SIP user 
Enter the SIP user name that will be used by the Dispatch Center. 
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5.2 Configuring TRBOnet Dispatch Console 
To start TRBOnet Server, click the corresponding shortcut on the desktop, 
or click Start > All Programs > Neocom Software > TRBOnet Dispatch x.x 
The dialog box will appear prompting you to enter the TRBOnet Server IP address, 
User Name, and Password. The default Administrator credentials are admin for the 
login and admin for the password. 
For a more detailed information on how to use TRBOnet Dispatch Console, refer to 
TRBOnet Enterprise User Manual. 

5.2.1 Registering Radio Groups 
Go to Administration (1), Radio Group (2) to add/edit/delete Radio Groups in the 
system. 

 

• Click Add (3) to add a radio group to the system: 
• In the dialog box that appears, specify the Name and Group ID (Radio ID) of 

the group you are adding. 

Note: Make sure that the radio group(s) created in the Dispatch Console 
are present in the radio’s RX Group List (see section 4.3.4, RX 
Group Lists). 
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5.2.2 Registering Radios 
Go to Administration (1), Radios (2) to add/edit/delete Radios in the system. 

 

• Click Add MOTOTRBO Radio (3) to add a new radio. 
• In the dialog box that appears, specify the Callsign, Radio ID, Radio Groups, 

and Home Group to which the radio belongs. 
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5.2.3 Registering SIP extensions 
This section describes how to add SIP extensions to TRBOnet Dispatch Console. 

• Go to Administration (1), Telephony (2). 
• In the Telephone pane, click the Extensions tab (3), and then Add > SIP 

Phone (4). 

 

• In the dialog box that appears, specify the SIP ID and SIP User of the SIP user 
you are adding. 
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